⌛ Z4 E89 - Grundlagen Dachhydraulik ☕

OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Naja. Wenn ich Angst hätte vor dem Problem, würde ich an dem Stecker zum Pumpenmotor/Temperatursensor eine Timeoutüberwachung einfügen. Also einen Leistungsschalter, der pro Aktivierung des Motors nicht mehr als z.B. 60s den Strom freigibt. Das wäre sogar völlig reversibel.

Hmm, die Bauteile dieser Lösung müßte für 600W dimensioniert sein (12V * max 50A). Gibt's sowas in klein und unauffällig?
Update 05/2019: Mittlerweile haben wir 36A als max. Strom gemessen, den die Pumpe zieht

Angst habe ich vor diesem Problem (noch) nicht, aber es ist jetzt der Dritte Z4 E89, von dem ich von so einen Schaden gehört habe. Aus meiner Sicht auch ein beginnendes Problem mit zunehmendem Alter der Fahrzeuge. Bei Pumpenpreisen von jetzt 2.700€ ist eine Schutzlösung durchaus einen zusätzlichen Gedanken wert.

Zumindest sollte man alle 2-4 Jahre je nach Nutzungsintensität die beiden Relais wechseln, um das Risiko zu begrenzen.
 
Zuletzt bearbeitet:

MiSt

macht Rennlizenz
Mitglied seit
5 November 2010
Standort
Frankfurt am Main
Wagen
BMW Z4 e89 sDrive23i
Auf Grundlage z.B. eines BTS555 könnte man sowas verschleißfrei bauen: https://www.infineon.com/dgdl/Infin...N.pdf?fileId=5546d4625a888733015aa3f57e5e103e

EDIT: Nochmal beim Warten auf das Mittagessen drüber nachgedacht :D - ganz so einfach wird's nicht wegen des Polaritätswechsels an den beiden Motorklemmen. Einfacher anstelle des Eingriffs direkt am Motor wäre ein Eingriff in die Plusversorgung der Relais (mit dem o.g. Baustein, ganz straightforward).
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Auf Grundlage z.B. eines BTS555 könnte man sowas verschleißfrei bauen: https://www.infineon.com/dgdl/Infin...N.pdf?fileId=5546d4625a888733015aa3f57e5e103e

http://www.zroadster.com/forum/inde...n-dachhydraulik.133304/#post-2753464Einfacher anstelle des Eingriffs direkt am Motor wäre ein Eingriff in die Plusversorgung der Relais (mit dem o.g. Baustein, ganz straightforward).
Korrrrrrekt,
Deswegen wird evtl. auch ein Simpel-Summer nicht funktionieren, da die meist polaritätsgebunden sind. Muß ich mal schauen und evtl. ausprobieren, ob es auch welche für "Wechselstrom" gibt.

Das mit den Relaisklemmen kannst du auch knicken! :D

Die werden nämlich korrekterweise vom CTM abgeschaltet, die Relais bleiben aber kleben und leiten den Strom weiterhin. ZZZZZzzzz machts trotzdem in der Pumpe.
 

mick70

Längs- beschleuniger
Mitglied seit
14 Juni 2009
Wagen
BMW Z4 e89 sDrive35i
Polarität ist ein Problem, ich wüsste keinen Summer, der an Gleichstrom unabhängig von der Polung betrieben werden kann.

Deshalb einfach 2 Summer, ist ja Platz da drunten. Jeweils ne Diode davor?
 
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Aber es gibt für fast alles eine simple Lösung:

BAAS BLE2 Akustischer Mini-Blinksummer
Louis Motorrad - der hatte ihn bei mir um die Ecke für 10€ vorrätig
Conrad Elektronik
Voelkner
AMAZON
...

_BLE2_small.jpg

Dieser Blinker-Summer hat insgesamt 3 Anschlüsse, wie geschaffen für unseren Zetti:
- Masse
- Plus Links
- Plus Rechts

Top, die beiden Plus-Eingänge sind voneinander entkoppelt(!), damit bei der Umpolung der Pumpe kein Kurzschluß entsteht. Das habe ich gerade schon getestet.

20180713_183612_small.jpg

Wichtig: die beiden Bleche in den beiden blauen Stromdieben sind jeweils auf einer Seite aufzubiegen/verbreitern, damit die dickeren Kabelquerschnitte der Pumpe dort passen und die Leitungen nicht durchtrennt werden.

Ich habe die beiden grauen Plus-Leitungen direkt an dem kurzen Stück Kabel der Pumpe noch vor dem 4-poligen Stecker befestigt. Sollte tatsächlich mal Dauerstrom auf der Pumpe liegen, dann würde durch Öffnen des Steckers auch der Piepser ausgehen.

20180713_183641_small.jpg

Die schwarze Minusleitung hat eine Ringöse gecrimpt. Dafür gibt es direkt auf Höhe der beiden rosa Relais am Heckblech einen Masse-Schraubanschluß. Als wenn einer der BMW Ingenieure diese Installation vorhergesehen hätte. :) :-)

20180713_183658_small.jpg

Durch die Lagerung des Piepsers innerhalb der Schaumstoffkiste der Pumpe ist das Geräusch wahrnehmbar, aber deutlich gedämpft.

Viel interessanter finde ich, daß dieser Piepser jetzt genau die Schaltzyklen akkustisch wiedergibt, die ich gestern erst mit den AD-Wandlern aufgezeichnet hatte. Perfekt! :D

Ich hab's nun final montiert und den Piepser in das kleine Schaumstoffach neben der Pumpe gelegt.
Durch die Bodenabdeckung und in meinem Fall den Roadsterbag-Geigenkasten ist das Geräusch ziemlich gedämpft, aber wahrnehmbar.

Sollte diePumpe warum-auch-immer in einen Dauerbetrieb umschalten, fällt dieses Geräusch auf jeden Fall auf. Klingt fast genauso wie meine Benzinpumpe, die auch immer mal wieder lauter surrt. :thumbsup:

Update 15.07.2018
In einem netten Telefonat mit @L-X habe ich erfahren, daß er tatsächlich mitbekommen hatte, daß seine Pumpe nach Schließen des Daches und Verlassen des Fahrzeugs weiter gesummt/gepumpt hat.

Da das Auto aber immer irgendwelche Geräusche nach dem Abstellen von sich gibt, ist ihm der Ernst der (Pumpen-)Lage nicht bewusst gewesen.

=> Wichtiger Hinweis:
Nach dem Abstellen und Abschließen des Fahrzeugs immer auf "komische" Pump- und Summ-Geräusche achten!
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Deswegen schrieb ich ja auch
:D
Verstehe ich nicht.
Die Plusversorgung der Spule kommt vom CTM, wird korrekt abgeschaltet.
Die Plus- und Minusversorgungen am Wechsler führt jeweils direkt zur Batterie, sind also dauerhaft unter Strom.
 
Zuletzt bearbeitet:

MiSt

macht Rennlizenz
Mitglied seit
5 November 2010
Standort
Frankfurt am Main
Wagen
BMW Z4 e89 sDrive23i
Ich meine diese Leitung, die, die mit 50A abgesichert ist und den vollen Pumpenstrom führt. Dort könnte man einen BTS555 einschleifen, der bei jedem Pegelwechsel an den Relais-Steuerleitungen den Strom für maximal z.B. 60s freigibt:

upload_2018-7-13_18-41-33.png
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Mir fehlte die Vorstellungskraft für Deinen "Eingriff". :roflmao:
 

pixelrichter

Umbau Hydraulikpumpe e85
Special Member
Sponsor
Mitglied seit
26 April 2011
Standort
97907 Hasloch, Im Battl 8
Wagen
anderer Wagen
Gibt's ein Update zu den Relais und der kochenden/stinkenden Pumpe?
Leider habe ich ihn nicht mehr ans Telefon bekommen.
Seine Mutter verspricht jedesmal, dass ihr Sohn zurückruft.
Nach 3 versuchen den Sohn zu erreichen war die Mutter doch leicht genervt. Somit eine kalte Spur :mad:
Ich habe nur die Festnetznummer. Da hebt die Mutter nach einem halben Klingelton schon ab..... Schade
 

pixelrichter

Umbau Hydraulikpumpe e85
Special Member
Sponsor
Mitglied seit
26 April 2011
Standort
97907 Hasloch, Im Battl 8
Wagen
anderer Wagen
Aber es gibt für fast alles eine simple Lösung:

BAAS BLE2 Akkustischer Mini-Blinksummer
Louis Motorrad - der hatte ihn bei mir um die Ecke für 10€ vorrätig
Conrad Elektronik
Voelkner
AMAZON
...



Dieser Blinker-Summer hat insgesamt 3 Anschlüsse, wie geschaffen für unseren Zetti:
- Masse
- Plus Links
- Plus Rechts

Top, die beiden Plus-Eingänge sind voneinander entkoppelt(!), damit bei der Umpolung der Pumpe kein Kurzschluß entsteht. Das habe ich gerade schon getestet.

Anhang anzeigen 316501

Wichtig: die beiden Bleche in den beiden blauen Stromdieben sind jeweils auf einer Seite aufzubiegen/verbreitern, damit die dickeren Kabelquerschnitte der Pumpe dort passen und die Leitungen nicht durchtrennt werden.

Ich habe die beiden grauen Plus-Leitungen direkt an dem kurzen Stück Kabel der Pumpe noch vor dem 4-poligen Stecker befestigt. Sollte tatsächlich mal Dauerstrom auf der Pumpe liegen, dann würde durch Öffnen des Steckers auch der Piepser ausgehen.

Anhang anzeigen 316500

Die schwarze Minusleitung hat eine Ringöse gecrimpt. Dafür gibt es direkt auf Höhe der beiden rosa Relais am Heckblech einen Masse-Schraubanschluß. Als wenn einer der BMW Ingenieure diese Installation vorhergesehen hätte. :) :-)

Anhang anzeigen 316499

Durch die Lagerung des Piepsers innerhalb der Schaumstoffkiste der Pumpe ist das Geräusch wahrnehmbar, aber deutlich gedämpft.

Viel interessanter finde ich, daß dieser Piepser jetzt genau die Schaltzyklen akkustisch wiedergibt, die ich gestern erst mit den AD-Wandlern aufgezeichnet hatte. Perfekt! :D

Ich hab's nun final montiert und den Piepser in das kleine Schaumstoffach neben der Pumpe gelegt.
Durch die Bodenabdeckung und in meinem Fall den Roadsterbag-Geigenkasten ist das Geräusch ziemlich gedämpft, aber wahrnehmbar.

Sollte diePumpe warum-auch-immer in einen Dauerbetrieb umschalten, fällt dieses Geräusch auf jeden Fall auf. Klingt fast genauso wie meine Benzinpumpe, die auch immer mal wieder lauter surrt. :thumbsup:

Update 15.07.2018
In einem netten Telefonat mit @L-X habe ich erfahren, daß er tatsächlich mitbekommen hatte, daß seine Pumpe nach Schließen des Daches und Verlassen des Fahrzeugs weiter gesummt/gepumpt hat.

Da das Auto aber immer irgendwelche Geräusche nach dem Abstellen von sich gibt, ist ihm der Ernst der (Pumpen-)Lage nicht bewusst gewesen.

=> Wichtiger Hinweis:
Nach dem Abstellen und Abschließen des Fahrzeugs immer auf "komische" Pump- und Summ-Geräusche achten!

Ich hab jetzt mal die 10 € investiert :thumbsup:


.
 
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Schadenanalyse Teil 1/2

Fehlermöglichkeit 5:
- CTM steuert die Relais zum Pumpen an
- Relais 1 zieht an, Kontaktzunge verschmilzt durch den Lichtbogen beim Schalten (bis zu 50A sind möglich, dann fliegt die Sicherung)
- Relais 2 bleibt stromlos wg. der Drehrichtung
- Pumpe läuft los
- CTM schaltet Relais1 ab, aber der Kontakt kann sich nicht mehr lösen
- Pumpe läuft weiter
- Pumpe wird warm

- CTM ist längst eingeschlafen mangels Dach oder Türbetätigung
- CTM überprüft keinen Temperatursensor mehr
- CTM kann sowieso nicht eingreifen, wenn das Relais hängt bzw. der Kontakt verschmolzen ist
- Pumpe wird heiß
- Exitus der Pumpe (12V*max. 50A = 600W), Kabel können schmoren, evtl. Brandgefahr

Krass, wäre aber nicht 100%ig auszuschließen
Von @L-X wurden mir die defekten Teile (Pumpe, 2 Relais) zugeschickt.

20180804_113236_small.jpg

Als erstes habe ich mir die beiden Relais vorgeknöpft, die L-X (oder die Werkstatt?) bereits geöffnet hatte:

20180804_115309_small.jpg
  • Relais 1
    Baujahr KW 11/2009, vermutlich die Original-Relais gemäß Baujahr des Fahrzeugs
    Die Relais-Spule ist in Ordnung, hat 79 Ohm als Widerstand.
    Laut Schaltplan auf dem rosa Gehäusedeckel gibt es einen Parallelwiderstand zur Relaisspule.
    Die Spule ist in Ordnung, der Umschaltkontakt funktioniert und schaltet zwischen beiden Kontakten hin und her. TOP :thumbsup:

    20180804_114814_1_small.jpg

  • Relais 2
    Baujahr KW 11/2009
    Die Relais-Spule ist in Ordnung, hat 79 Ohm als Widerstand.

    Die Spule ist in Ordnung, aber der Umschaltkontakt liegt NICHT(!) im Ruhezustand, sondern ist fest mit dem 2. Kontakt verbunden.
    20180804_115148_2_small.jpg

    rot - Wechselschalter
    grün - linker und rechter Kontakt
    blau - Umschaltkontakt
    20180804_115148_2_small1a.jpg

    Vergrößerung der Kontaktzungen - links der feste Kontakt, rechts der bewegliche Umschaltkontakt

    Hier sieht man, dass der mittlere Kontakt, der im Ruhezustand (stromlos) mit dem linken Kontakt verbunden sein muß (siehe Relais 1), fest am rechten Kontakt (nicht sichtbar) klebt, mit diesem also verschmolzen(!) ist.


    20180804_115148_2_small1b.jpg

Damit ist genau das oben von mir skizzierte Worst-Case-Szenario (Fehlermöglichkeit 5) eingetreten:

Aufgrund des verschmolzenen Relais-Kontaktes wird die Pumpe nach Abschluß der Dachbewegungn nicht mehr abgeschaltet, sondern läuft mit voller Leistung unkontrolliert weiter. Dies macht sie so lange, bis entweder die Sicherung durchbrennt oder die Pumpe kaputt geht oder...

... abwarten, was die Überprüfung der Pumpe ans Licht bringt.



Meine EMPFEHLUNG
:

Nachfolgender Beitrag zum Tausch meiner beiden Relais vor 1 Jahr mit diversen Bildern der Relais-Kontakte:
http://www.zroadster.com/forum/index.php?threads/dach-schließt-nicht-mehr-gelöst.86891/page-16#post-2521765



Relais-Wechsel:

20180713_183612_small.jpg

$_57c.JPG

Relaistausch3.jpg

Relaistausch4.jpg



===========================================================



DRINGENDE WARNUNG:

Ausnahmslos bei allen Z4 E89 sollten die beiden rosa Relais im Kofferraumboden sofort getauscht werden, wenn das bisher noch nicht gemacht wurde oder das Alter der Relais nicht bekannt ist.


===========================================================


 
Zuletzt bearbeitet:

pixelrichter

Umbau Hydraulikpumpe e85
Special Member
Sponsor
Mitglied seit
26 April 2011
Standort
97907 Hasloch, Im Battl 8
Wagen
anderer Wagen
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Dann bestell ich mir mal welche.
Bevor BMW das mitbekommt und den Preis, ähnlich wie beim Hallsenser nach oben schraubt :mad:
Hammse schon: von 12€ in 2017 auf knapp 16€ in 2018 :roflmao:

Wir sollten uns mal Gedanken über ein Alternativ-Relais machen, die anderen Hersteller verbauen sicher gleiche Modelle.

Es gibt allerdings auch eine deutlich teurere Variante: :eek: :o
https://www.amazon.de/Salmon-SIEMENS-V23134-E52-X344-1742690-12631742690/dp/B076GP9L8G

Und dann gibt's noch einen Fashion-Store, der sie für nur 3€ anbietet: &:
https://www.sikomarket.top/electron...siemens-v23134e52x34wbr4-bmw-relay-p-7065.htm
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Schadenanalyse Teil 2/2

  • Hydraulikpumpe - Ui Ui Ui uiuiuiuiuiu...
Typschild der Pumpe bzw. Schalteinheit, leider ohne Leistungsangabe und ohne Datum:
318829
Update 15.04.2019: Das Produktionsdatum ist KW13/2009

Die Isolierung der Drähte zwischen dem 4-poligen Stecker und dem Gehäuse sind geschmolzen, es gab aber KEINEN Kurzschluß:
318818

Pumpengehäuse öffnen
318819

Dabei rieselte irgendwas Schwarzes raus:
318821

318822

Im Gehäuse sind an der Außenwand 3 Permanentmagnete vernietet. Sonst gehört dort nichts rein. Was Ihr zusätzlich seht hat Ähnlichkeit mit den Bildern aus dem geschmolzenen Tschernobyl-Reaktor (Stichwort "Elefantenfuß"):
318823

318824

Alle Trümmer-Teile (geschmolzener Kunststoff):
318827

Motoraufbau:
318826


These:
Durch den Dauerbetrieb der Pumpe aufgrund des defekten Relais ist eine enorme Hitze entstanden. Dadurch bedingt sind die im Motor verbauten Kunststoffteile (Halter, Lager, Isolatoren,...) geschmolzen und haben die beweglichen Teile verklebt. Das muß tatsächlich eine dünnflüssige Masse ergeben haben, wie man an den erkalteten Strukturen erkennen kann.

Wie schon geschrieben, haben die äußeren Anschlüsse trotz geschmolzener Isolierung KEINEN Kurzschluß verursacht. Also muß zwischen dem inneren Anschluß auf der Platine und der Verbindung zum Schleifer eine Unterbrechung sein, die ich noch nicht gefunden habe.

Interessant ist, daß die Wicklung des Motors intakt ist und ich an den beiden Schleifern einen Wicklungs-Widerstand von 18 Ohm messen kann. Der erscheint mir aber zu hoch: I=U²/R = 8A bei 12V, Leistung wäre dann "nur" 100W. Da hätte ich weniger Widerstand erwartet.

Durch diese Unterbrechung (mal sehen, ob ich da noch was finden werde...) stoppte der Motor, die heiße Kunststoff-Masse erkaltete und verklebte alle beweglichen Teile.

Exitus

Update 13. August 2018
Diskussion:

Defekte Hydraulikeinheit oder defektes Relais?

BMW Z4 E89 Grundlagen Dachhydraulik



Update 15.04.2019
Zwichenzeitlich haben wir durch Vergleich mehrerer Pumpen herausgefunden, wie das Alter der Pumpe bestimmt werden kann.


373652

Links im roten Kasten steht das Produktionsdatum im Format [YYWW], also Jahr & Kalenderwoche. Im rechten Kasten steht eine 4-stellige laufende Nummer [XXXX] in dieser Produktionswoche.
Die @L_X Pumpe wurde also als 105. Pumpe in der Woche 13/2009 produziert.
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Zuletzt bearbeitet:
Oben Unten