⌛ Z4 E89 - Grundlagen Dachhydraulik ☕

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
BITTE HIER NICHT MÜLLEN, da kommen jetzt noch einige Beiträge von mir!



Ich hatte heute mit @pixelrichter eine Diskussion bzgl. der E89 Dachhydraulik,

Weil das dann doch tiefer in die Grundlagen ging als gedacht, würde ich dieses hier für alle noch einmal zusammen fassen.

Hallo Robbi.
Es gab hier doch mal das Thema, dass wir meinten, dass eine Verdeckpumpe zu heiß lief und abschaltete weil die Werkstatt das Dach öfters auf- und zu gemacht hatte.

Dann gab es das Thema mit den angeschmorten Steckern

Heute wurde ich angerufen, dass eine Verdeckpumpe sehr sehr heiß wird, obwohl das Dach gar nicht bewegt wurde. Es hat während der normalen Autofahrt verschmort gestunken. Gefunden wurde dann die Pumpe.

Meine Empfehlung war erst mal die Batterie und die 2 Relais abziehen.
Wenn weitergefahren wird, läuft ohne die Relais kein Strom zum Motor, also kann erst mal nix weiter passieren.
Kannst du ein Überwachungstool bauen der den Motor Temperaturmäßig überwacht und Alarm gibt?

Das Abziehen beider Relais reicht auf jeden Fall, um die Hydraulik-Pumpe stillzulegen. Dafür reicht übrigens auch Abziehen des breiten 4-poligen schwarzen Pumpensteckers. :thumbsup:
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Die Temperatur-Info stammt u.a. aus diesem PDF-Dokument Seite 25, habe ich aber auch im NewTIS gesehen:

http://weblog.pac1.net/_Documents/140610_BMW_Z4(E89)-05_product_description.pdf
The retractable hard top can be opened and closed using the button in the center console only if the following conditions are met:​
• Terminal RON​
• Outside temperature above -12°C​
• Boot lid closed​
• Vehicle stationary (driving speed <0.7 km/h)​
• Luggage compartment partition in lowest position​
• Lateral inclination of vehicle < 11°​
• Power windows initialized​
• Battery voltage >11.5 V​
• Less than five successive opening/closing operations​
• Hydraulic fluid temperature for opening <90°C and for closing <105°C
• Electrical system check successful​
• Production ,transport and workshop mode (FeTraWe) not set .​

Seite 23:
Two cables connect the temperature sensor ground-free to the convertible top module. A line break (open circuit) results in a fault code being entered in the fault code memory.

Ich habe bisher noch keine Pumpe komplett in der Hand gehabt, nur meine mal leicht angehoben um den Ölstand zu sehen. Daher weiß ich noch nicht, wo der Temperatursensor sitzt. Entweder IN der Pumpe oder am Gehäuse angeflanscht. Angeschlossen ist die Pumpe unten am Pumpenkasten mit einem 4-poligen Stecker: 2 dicke Drähte für den Pumpenstrom, 2 dünne Drähte für den Temperatursensor.

Die Empfehlung mit den Relais ist sicher korrekt!

Einfacher finde ich, den 4-poligen Stecker zu trennen anstatt die Relais zu ziehen (ist für Ungeübte ein wenig fummelig).

Die beiden Relais liegen links unten, der Stecker rechts oben:
20180712_161958_small.jpg
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Nachfolgend die elektrische Schaltung:
Quelle: NewTIS:



Irgendwie unlogisch, daß die Pumpe dauerhaft unter Strom stehen sollte. Das wird immerhin direkt vom Dachmodul gesteuert (glaube ich??)

Was passiert aber elektrisch, wenn ein defektes Relais am Kontakt kleben bleiben sollte? Daß muß ich mir mal aufzeichnen und drüber nachdenken...

In der Doku sieht man den Temp.Sensor nahe bei der Pumpe. Das der aber dauerhaft überwacht wird, bezweifle ich.


Idee:
Ich könnte mein Diagnosekabel dahingehend abwandeln, daß ich auch den Temperatur-Sensor über den AD-Wandler laufen lasse. Mal sehen, was für Werte dieser Sensor ausspuckt.

Was passiert aber elektrisch, wenn ein defektes Relais am Kontakt kleben bleiben sollte? Daß muß ich mir mal aufzeichnen und drüber nachdenken...

Update 31.07.2018
Der nachfolgende Absatz hat sich als nicht ganz korrekt bzw. unvollständig herausgestellt!
Das ist egal. :@
Die beiden Relais sind als Polwechsler geschaltet. Angesteuert durch das CTM sorgen sie dafür, daß der Motor der Pumpe links rum oder rechts rum läuft, indem Plus und Minus am Motor getauscht werden. Sollte 1 Relais kaputt sein und hängen bleiben, bekommt der Motor eben 2 mal Minus oder 2 mal Plus. Ein defektes Relais kann also kein Folgeproblem verursachen [FALSCH!], lediglich das Dach bewegt sich nicht . :roflmao:


Was mir aber zum Verständnis der Pumpe noch fehlt, ist die Steuerung der Klemme X498 ganz links unten im Stromlaufplan:

Die darf nicht dauerhaft Minus führen, sonst würde die Pumpe permanent laufen - und heiß werden. Da dieser Zustand sicher nicht vom CTM überwacht wird, wäre das ggf. die Ursache für die Hitzeentwicklung.

Woher kommt X498?
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Woher kommt X498?

X498
ist der Massekamm im Kofferraum. Nach obigem Schaltplan läge die Pumpe also immer an Dauerplus und Dauerminus! Lediglich die Drehrichtung würde durch das CTM und die beiden Relais gewechselt.

Aber irgendeine Komponente muß den Strom zur Pumpe doch auch wieder unterbrechen. Das sehe ich aber nicht im Schaltplan...

Wäre es denkbar daß der Motor IMMER läuft um den Druck zu halten? Und bei Bedarf werden nur die Ventile freigegeben? Dann würde mich eine Überhitzung nicht wundern.

NewTis Übersicht:
BMW E89 Z4 sDrive30i Roadster


Dauerplus bis Relais:
Sicherung F107




Dauerminus bis zum Relais:
Masseanschluss X498



Das kann ich mir nicht vorstellen. :D

Das Ding liefe nach dem Schaltplan IMMER. Kann ich mir aber auch nicht vorstellen. :roflmao:
Aber dann fehlt in der o.g. Doku ein Steuerlement, daß diesen Stromfluß unterbricht.


Arrrrrggghhhhh - hab's gefunden. Die sind echt verrückt, die Jungs bei BMW.
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Auszug aus obigem Gesamt-Schaltplan
Quelle: NewTIS:




Darüber hatte ich mich eben schon gewundert, als ich die Relais-Schaltung von Hand gezeichnet hatte. Im obigen Schaltplan aus dem NewTIS gibt es einen zeichnerischen Fehler!

Beide Relais sind identisch aufgebaut, gleiche Teilenummer, gleiche Pinbelegung, wahlfrei zu verbauen.
Dann sollten auch bei beiden Relais die Kontake 5 und 6 im Ruhezustand verbunden sein sowie 2 und 6 bei angezogenem Relais. Das ist oben beim linken Relais falsch gezeichnet. Nachfolgend die korrekte Beschaltung:

317226

So funktionierts:
An beiden Relais liegt an den Klemmen 5 jeweils Dauerplus, an beiden Klemmen 2 Masse. Beide sind also gleich beschaltet.

Sind beide stromlos auf der Wicklung, leiten beide Zweige Plus an den Motor, er läuft NICHT.
Sind beide Relais angezogen, dann liegt jeweils Minus an beiden Motoranschlüssen, Motor läuft ebenfalls NICHT.

Somit muß das CTM immer 1 Relais ansteuern, daß andere abgefallen lassen, damit der Motor los läuft. Für den Wechsel der Drehrichtung sind die beiden Relais umgekehrt anzusteuern, aber immer 1 angezogen, 1 abgefallen.
=> Ohne die aktive Logik des CTM's geht da gar nichts, kann die Hydraulikpumpe also NICHT von selber laufen!

Diese Vorgehensweise hat den Vorteil, daß die Pumpe beim Abschalten nicht langsam bis zum Stillstand "ausläuft", sondern abrupt stehen bleibt, der Druck ist somit sofort reduziert.
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Somit wissen wir immer noch nicht, warum die Pumpe sehr heiß wird, obwohl sie nicht läuft.
:poop: & Korrekt.

Fehlermöglichkeit 1:
Wenn der Motor dauerhaft läuft, dann hat das Steuergerät CTM eine Endposition der Hydraulik nicht erkannt. => Motor läuft heiß.
=> der Temp.Sensor sollte ansprechen, CTM schreibt Fehler ins Protokoll

Fehlermöglichkeit 2:
Wenn die Pumpe heiß wird während des "geplanten" Laufens, dann ist entweder
- die Lagerung des Motors defekt
- ein großer mechanischer Widerstand im Öl
- ein Ventil verstopft/defekt
- das CTM Steuergerät "vergißt" die Pumpe abzuschalten (CTM defekt?)
=> der Temp.Sensor sollte ansprechen, CTM schreibt Fehler ins Protokoll

Fehlermöglichkeit 3:

- Das CTM spinnt/ist defekt und hält eines der beiden Relais dauerhaft angezogen.
=> Motor läuft dauerhaft und wird heiß. Ggf. würde dann auch das Abschalten durch den Temperatursensor nicht funktionieren, aber ich würde einen Eintrag im Fehlerspeicher erwarten.

Fehlermöglichkeit 4:
Fällt das CTM jedoch aus oder stromlos ist, dann fehlt wie oben bereits beschrieben das 1 angezogene Relais für den Pumpenbetrieb
=> der Motor erhält KEINEN Strom und bleibt kalt

Weitere Fehler-Möglichkeiten?
 
Zuletzt bearbeitet:

torspeed

Active Member
Active Member
Mitglied seit
17 Mai 2010
Standort
52538 Gangelt
Wagen
BMW Z4 e89 sDrive35i
Ich bin zwar kein Elektroniker, aber ich glaube nicht, dass das CTM ein hängendes Relais erkennt, oder? Wenn am Ende des Schließ- oder Öffnungsvorgangs das aktivierte Relais hängen bleibt, läuft die Pumpe weiter, ohne dass es bemerkt wird.

Sven
 

pixelrichter

Umbau Hydraulikpumpe e85
Special Member
Sponsor
Mitglied seit
26 April 2011
Standort
97907 Hasloch, Im Battl 8
Wagen
anderer Wagen
Ich bin zwar kein Elektroniker, aber ich glaube nicht, dass das CTM ein hängendes Relais erkennt, oder? Wenn am Ende des Schließ- oder Öffnungsvorgangs das aktivierte Relais hängen bleibt, läuft die Pumpe weiter, ohne dass es bemerkt wird.

Sven
Und wahrscheinlich könnte dies der Grund wegen der heißgelaufenen Pumpe sein, weswegen ich angesprochen wurde.
Wir sind noch auf der fehlersuche, teils theoretisch, teils praktischer Natur ;)
 
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Ich bin zwar kein Elektroniker, aber ich glaube nicht, dass das CTM ein hängendes Relais erkennt, oder? Wenn am Ende des Schließ- oder Öffnungsvorgangs das aktivierte Relais hängen bleibt, läuft die Pumpe weiter, ohne dass es bemerkt wird.
Sven
Eine Störungs-Erkennung gibt es definitiv nicht.
 
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
[...]Weitere Fehler-Möglichkeiten?

Fehlermöglichkeit 5:
- CTM steuert die Relais zum Pumpen an
- Relais 1 zieht an, Kontaktzunge verschmilzt durch den Lichtbogen beim Schalten (bis zu 50A sind möglich, dann fliegt die Sicherung)
- Relais 2 bleibt stromlos wg. der Drehrichtung
- Pumpe läuft los
- CTM schaltet Relais1 ab, aber der Kontakt kann sich nicht mehr lösen
- Pumpe läuft weiter
- Pumpe wird warm

- CTM ist längst eingeschlafen mangels Dach oder Türbetätigung
- CTM überprüft keinen Temperatursensor mehr
- CTM kann sowieso nicht eingreifen, wenn das Relais hängt bzw. der Kontakt verschmolzen ist
- Pumpe wird heiß
- Exitus der Pumpe (12V*max. 40A ~ 500W), Kabel können schmoren, evtl. Brandgefahr

Krass, wäre aber nicht 100%ig auszuschließen
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Und wahrscheinlich könnte dies der Grund wegen der heißgelaufenen Pumpe sein, weswegen ich angesprochen wurde.
Wir sind noch auf der Fehlersuche, teils theoretisch, teils praktischer Natur ;)
Dann müßtest Du aber unbedingt beide Relais ausbauen, die Gehäuse öffnen (Deckel ist nur eingerastet) und die Kontakte überprüfen. Verschmolzen?


Hier mein Beitrag aus 2017 mit Bildern von den geöffneten Relais:
http://www.zroadster.com/forum/index.php?threads/dach-schließt-nicht-mehr-gelöst.86891/page-16#post-2521765
 
Zuletzt bearbeitet:

pixelrichter

Umbau Hydraulikpumpe e85
Special Member
Sponsor
Mitglied seit
26 April 2011
Standort
97907 Hasloch, Im Battl 8
Wagen
anderer Wagen
Dann müßtest Du aber unbedingt beide Relais ausbauen, die Gehäuse öffnen (Deckel ist nur eingerastet) und die Kontakte überprüfen. Verschmolzen?
Ich könnte morgen mal mit dem Besitzer der heißgelaufenen Pumpe telefonieren.
Er will sich sowieso neue kaufen, hoffentlich hat er die alten Relais noch.

Und es gab hier schon öfters den Tipp, dass man die Relais ruhig mal zwischendurch tauschen sollte. Kosten ja nur ca. 15 Euro/Stück und sind frei zugänglich im Kofferraum.

IMG_2438-k.jpg
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Und es ga hier schon öfters den Tipp, dass man die Relais ruhig mal zwischendurch tauschen sollte. Kosten ja nur ca. 15 Euro/Stück und sind frei zugänglich im Kofferraum.
Diskussion u.a. vom letzten Jahr. Aber das war ja nur auf Verdacht, daß das Dach irgendwann wg. eines defekten Relais nicht mehr funktionieren würde.

Hier zeichnet sich aber ein völlig anderes Fehlerszenario ab. :confused:


Deswegen habe ich auch zuerst nicht verstanden, wie das funktionieren soll.
Arrrrrggghhhhh - hab's gefunden. die sind echt verrückt, die Jungs bei BMW.
:j
War mein erster Eindruck doch richtig.

Idee:
Interessant wäre, ob diese verrückte Schaltung auch bei den anderen Cabrios verbaut wurde oder ob das eine Zetti-Besonderheit ist.
 
Zuletzt bearbeitet:

pixelrichter

Umbau Hydraulikpumpe e85
Special Member
Sponsor
Mitglied seit
26 April 2011
Standort
97907 Hasloch, Im Battl 8
Wagen
anderer Wagen

MiSt

macht Rennlizenz
Mitglied seit
5 November 2010
Standort
Frankfurt am Main
Wagen
BMW Z4 e89 sDrive23i
Die Schaltung mit den zwei Relais zur Umpolung ist nicht sonderlich exotisch. Schöner wäre natürlich, es wären keine mechanischen Schalter und/oder das korrekte Schalten würde überwacht.

Wenn man der Sache auf den Grund gehen will, könnte man womöglich
- die Pumpe abklemmen und z.B. eine Lampe statt des Motors anschließen
- ein hängendes Relais durch Ziehen und Brücken des entsprechenden Kontakts simulieren

Wenn das Auto bzw. das Steuergerät dann tatsächlich friedlich einschläft, ... uiuiuiuiui :eek: :o
 

mick70

Längs- beschleuniger
Mitglied seit
14 Juni 2009
Wagen
BMW Z4 e89 sDrive35i
Ohne mich bis jetzt bislang näher mit dem Thema auseinandergesetzt zu haben - wäre der Anschluss eines Summers parallel zum Pumpenmotor nicht eine Option, als Prophylaxe gegen ein hängendes Relais? Während das Verdeck verfährt, stört das Piepen nicht und warnt sogar vor dem versehentlichen Hineingreifen. Piepst es danach weiter, weiß man, dass als Sofortmaßnahme besser die Sicherung gezogen (ist die im Fußraum erreichbar?) oder je nach Dachzustand die Batterie abgeklemmt werden sollte.
 
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Die Schaltung mit den zwei Relais zur Umpolung ist nicht sonderlich exotisch. Schöner wäre natürlich, es wären keine mechanischen Schalter und/oder das korrekte Schalten würde überwacht.
Full Ack, aber das es keinen weiteren Ausschalter dafür gibt, halte ich für kritisch! Relais kaputt, Kraftwerk explodiert. Das ist nicht sonderlich intelligent, oder?

Wenn das Auto bzw. das Steuergerät dann tatsächlich friedlich einschläft, ... uiuiuiuiui :eek: :o
Genau, keine weitere thermische Überwachung mehr, obwohl die Pumpe in so einem Fehlerfalle weiterläuft.
Ich arbeite bereits an einem Anschluß für die AD-Wandler, um das genauer zu protokollieren...

@MiSt
In der o.g. PDF Dokumentation auf Seite 23 steht, daß der Sensor "massefrei" über 2 Drähte am CTM angeschlossen ist.
"The temperature in the hydraulic pump is measured to avoid the pump overheating during frequent use of the retractable hardtop. Two cables connect the temperature sensor ground-free to the convertible top module. Aline break (open circuit) results in a fault code being entered in the fault code memory."

Hast Du eine Vorstellung, was für ein Bauteil für diese Messung verwendet wird und wie könnte ich dessen Meßwert mit einem AD-Wandler im laufenden Betrieb protokollieren?
Muß ich mit 'nem Widerstand erst einen Spannungsteiler aufbauen, an dem ich dann den AD-Wandler anhängen kann?
 
Zuletzt bearbeitet:

MiSt

macht Rennlizenz
Mitglied seit
5 November 2010
Standort
Frankfurt am Main
Wagen
BMW Z4 e89 sDrive23i
Hast Du eine Vorstellung, was für ein Bauteil für diese Messung verwendet wird und wie könnte ich dessen Meßwert mit einem AD-Wandler im laufenden Betrieb protokollieren?
Muß ich mit 'nem Widerstand erst einen Spannungsteiler aufbauen, an dem ich dann den AD-Wandler anhängen kann?

K.A., warum dem Autor das so wichtig war mit dem "massefrei"? Das heißt eigentlich nur, dass der Sensor halt an keinem Ende auf Masse liegt - so what?

Was die Auswertung mit AD-Wandler angeht, so bedeutet das, dass man an beiden Enden messen muss und die Differenz bildet dann den zur Temperatur in Beziehung stehenden Wert:
- relativ wahrscheinlich ist das ein unlinearer Zusammenhang, wenn es sich um einen NTC oder - unwahrscheinlicher - PTC handelt
- es kann aber auch ein linearer Sensor eingebaut sein auf Halbleiterbasis

Schwierigkeiten bzw. die Notwendigkeit irgendeiner speziellen Beschaltung entstünde erst dann, wenn die Spannung an einem der Enden den Messbereich des AD-Wandlers verlässt. Ich würde aber erwarten, dass beide Enden sich im Bereich von über 0V ("massefrei") bis unter 5V bewegen.
 
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Ich will ja nichts am CTM kaputt machen durch das Anschließen meines AD-Wandlers. :eek: :o

Mein Problem:
der AD-Wandler legt grundsätzlich einen Anschluß auf Masse, der dann via USB mit dem Notebook verbunden ist.

Könnte ich alternativ beide Leitungen auf jeweils einen eigenen AD-Wandler Eingang legen und diese dann parallel gegen Masse messen. Müsste doch auch funktionieren, oder?
 

MiSt

macht Rennlizenz
Mitglied seit
5 November 2010
Standort
Frankfurt am Main
Wagen
BMW Z4 e89 sDrive23i
Könnte ich alternativ beide Leitungen auf jeweils einen eigenen AD-Wandler Eingang legen und diese dann parallel gegen Masse messen. Müsste doch auch funktionieren, oder?

Ja, so hatte ich das gemeint mit

... so bedeutet das, dass man an beiden Enden messen muss ...

Erst die Differenz der Kanalmessungen liefert dann das eigentliche Ergebnis sich irgendwie mit der Temperatur ändernder Werte.
 
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
Ich bin gespannt, was ich vorfinden werde. Selbst im NewTIS steht "Sensormasse" am Stecker X410 Pin8 :D

Nun habe ich mir auch die Hydrauliksteuerung in meinem Wagen genauer angeschaut.

373010

Der zweireihige Stecker X410 (2x 9-polig)

316386

Die beiden lila Drähte links (17+8) führen zum Temperatursensor der Hydraulikpumpe. Die Drähte 1+10 (orange) sind für Relais 1, die beiden Drähte 2+11(weiß) für Relais 2.

Dort habe ich mein zweites Interfacekabel angesteckt. Die Drähte des Interfacekabels haben vorne kleine Metallspitzen, die in Silikonschlauch stecken, der sich beim Einfädeln in den Stecker nach oben schiebt.

316387

Zu Beginn meiner Messungen erhielt ich den nachfolgenden Kurvenverlauf, den ich mir erst mal gar nicht erklären konnte:

316384

:D Dazu später mehr in den Einzelbetrachtungen...

Der Temperatursensor der Pumpe scheint Teil eines Spannungsteilers zu sein, da konnte ich über die beiden Kontakte Pin 8 und Pin 17 keine nennenswerte Spannungswerte messen.In nachfolgendem Chart des AD-Wandlers wird der Sensor beim Aktivieren des CTM's(!, nicht der Pumpe) mit Spannung versorgt, die Überwachung startet. Auch nach Abschalten der Pumpe wird der Sensor weiterhin vom CTM (Cabrio Top Modul) mit Spannung versorgt.

Bei längerer Beobachtung des Kurvenverlaufs fällt auf, daß der Spannungspegel mit zunehmender Erwärmung der Pumpe kontinuierlich fällt.

316382

CTM schaltet nach einer Weile wieder ab, der Temperatursensor ist funktionslos:

316383

Die von mir am Temp.Sensor gemessene Spannung ist über die Zeit von ca. 2 kompletten Dachzyklen immer weiter abgefallen, von ca. 1,1 V auf 0,84 V. Analog dazu stieg die Temperatur der Pumpe an, von anfangs handwarm über ca. 40° bis zu geschätzten 60°.

Sicher bin ich jetzt, daß keine weitere Temperaturüberwachung der Pumpe stattfindet, wenn das CTM sich schlafen gelegt hat.



Nun zu den Relais, deren Kurvenverlauf mich im ersten Chart massiv verwirrt hatten.

  1. Verwirrung:
    die AD-Wandler können nur max. 5 Volt am Eingang verarbeiten, dann wird der Kurvenverlauf abgeschnitten. Das CTM schaltet aber +12V auf die Relaisausgänge.

  2. Verwirrung:
    Auch die Ansteuerung der Relais und damit einhergehend die Drehrichtung der Pumpe ist komplexer als vermutet. Der Chartverlauf der orangen und grünen Kurve für Relais 1 und Relais 2 ist tatsächlich korrekt. :D
Nachfolgend das Notenblatt des Relais-Orchesters:

316389

Das erklärt die Verwirrung bei obigem ersten Chartverlauf für die beiden Relais. Mitten im Öffnen- und Schließenprozess wird die Drehrichtung der Hydraulikpumpe umgekehrt!

Absolut keine Erklärung habe ich dafür, daß die Pumpenrichtung beim Heckklappen-Öffnen zwischen Öffnen und Schließen gegenläufig ist. :eek: :o Ich habe es 2 mal gemessen und die gleichen Werte erhalten. Offensichtlich kann die Steuerung der Hydraulikventile dies ausgleichen.

Zum Abschluß werden beide Relais wieder stromlos geschaltet. Besonderheit hier ist, daß dies aus elektrischer Sicht einem "Kurzschluß" mit entweder 2x Plus oder 2x Minus entspricht. Dadurch wird die Pumpe sofort und ohne Nachlauf zum Stillstand gebracht.

Sollte aber in dieser Situation einer der beiden Relaiskontakte "hängen" bleiben (Relais defekt, Kontakt verklebt/verschmort), dann würde die Pumpe tatsächlich ohne Ende weiter laufen, bis sie den Hitzetod stirbt und vermutlich noch ein paar weitere Teile im Kofferraum zum schmoren bringt.

Again what learned. :D

Update 2019:
Nun gibt es auch ein "hübscheres" EKG der Aktivitäten der beiden lachsfarbenen Relais (Ausschnitt) =:
2019-04-12_Z4_E89_EKG_Hydraulic-1_Relais_Oeffnen_Small.jpg


Hier sieht man sehr schön, daß immer nur 1 Relais aktiv ist, während das 2. abgeschaltet ist. Außerdem erkennt man die Pause kurz vor dem Schließen des Kofferraumdeckels im roten Kurvenverlauf beim Öffnungsvorgang.
 
Zuletzt bearbeitet:
OP
RobbiZ4

RobbiZ4

Call me Dr. Bob. ☕
Active Member
Mitglied seit
21 Juni 2016
Standort
80333 ❤️
Wagen
BMW Z4 e89 sDrive30i
[...] wäre der Anschluss eines Summers parallel zum Pumpenmotor nicht eine Option, als Prophylaxe gegen ein hängendes Relais? Während das Verdeck verfährt, stört das Piepen nicht und warnt sogar vor dem versehentlichen Hineingreifen. Piepst es danach weiter, weiß man, dass als Sofortmaßnahme besser die Sicherung gezogen (ist die im Fußraum erreichbar?) oder je nach Dachzustand die Batterie abgeklemmt werden sollte.
So ein Mopped-Blinkerpiepser wäre eine wirksame Kontrollmaßnahme mit geringstem Aufwand. 8-) :D
 

MiSt

macht Rennlizenz
Mitglied seit
5 November 2010
Standort
Frankfurt am Main
Wagen
BMW Z4 e89 sDrive23i
Naja. Wenn ich Angst hätte vor dem Problem, würde ich an dem Stecker zum Pumpenmotor/Temperatursensor eine Timeoutüberwachung einfügen. Also einen Leistungsschalter, der pro Aktivierung des Motors nicht mehr als z.B. 60s den Strom freigibt. Das wäre sogar völlig reversibel.
 
Oben Unten